You are not logged in.

#1 2016-12-17 10:45:40

xlarve
Member

quake crashed when i testing my map

Hi!

Im making quake 1 map in original qauke 1 (openGL version proquake 4.52).

I think original q1 have limit of Peak memory usage.
I render bsp and have - Peak memory usage: 100047156 (95.4M) - when testing map in quake -  quake-game crashed.
When I use less Peak memory (delete part of the map) - map running good.

Can any-body say me what size of peak memory usage is for originally quake1?
I am right in my assumption or wrong?
I thinking that it has reached this limit of peak memory usage. And this is means that i must reduce my map (delete some brashes)...

Last edited by xlarve (2016-12-17 16:40:07)

#2 2016-12-17 18:12:27

xlarve
Member

Re: quake crashed when i testing my map

Hey, guys!
Now im sure that original q1 has a limit for peak memory usage.
Making tests.

I think the question is solved. In the map used some copied-test brushes (rooms), which give an approximate idea of how many brushes can I do for working map.

For peak memory usage: 100123538 (95.5M) - my map working.
conclusion: peak memory usage: 96M is limit for q1

If someone has a comment - write pls - maybe im wrong.

https://www.youtube.com/watch?v=wCfWftP … e=youtu.be

perhaps someone it will be useful, but who is now mfpping in the original game?..

Last edited by xlarve (2016-12-17 19:02:25)

#3 2016-12-17 22:59:30

negke
Moderator

Re: quake crashed when i testing my map

First of all, the Mapping Help thread at Func_Msgboard is a better place to ask such questions, because that forum is frequented by people who know about these things as opposed to this one here.

The peak memory usage has nothing to do with the crash; it just displays how much memory the QBSP process has used. Having said that, it's not clear to say what causes the crash, but if deleting that one room fixes it, it would suggest there must be a problem within that very room. There are several invalid strings in the map ("\ Q" etc) as the QBSP log shows, and faulty fields "classnametargetname" on two entities - though these don't appear to be the cause of the crash, either.

Hard to say without actually seeing the map/source. What you can try is: 1. Load the crashing map in some other engine, for example Quakespasm and see if it works flawlessly there or if you can detect something out of order. Might be some glitch in Proquake. Or 2. Try some other compiler - perhaps there's a problem or some feature it has that's unsupported by Proquake.

#4 2016-12-18 08:57:09

xlarve
Member

Re: quake crashed when i testing my map

thanks a lot. Im trying to solve the problem.

#5 2016-12-18 11:39:35

xlarve
Member

Re: quake crashed when i testing my map

I found what the problem was. Have brushes with skip-textures on the faces, this brushes gives liks. Now peak memory around 60 M.
Thank again, Negke!

Last edited by xlarve (2016-12-18 11:40:19)

Quick reply

Write your message and submit
Are you human or robot? If you have trouble, mail to spirit åt quaddicted døt c

Checking if this is requested by a real person and not an automated program.

Board footer