Post a reply

Write your message and submit
Are you human or robot? If you have trouble, mail to spirit åt quaddicted døt c

Checking if this is requested by a real person and not an automated program.

Go back

Topic review (newest first)

Fat_Angus
2021-07-17 08:46:48

I can confirm that it works!  It was that Spawnflag setting that did it.  Thanks guys!

triple_agent
2021-07-17 08:19:53

@'Gila', impressive competence.

Silly me, forgot the purpose was deathmatch, even if I knew what to search for or how to run a "deathmatch" mode in the first place.

But it seems like the situation is getting clearer.

EDIT:

Okay, tried my best and these are the errors the engine has output, when manually loading the map in multiplayer; for that sake, had to change the map location to "maps" folder within the "id1" directory:

Warning: PF_setmodel("progs/eyes.mdl"): Model was not precached

ERROR-OUT BEGIN

Shutting down SDL sound

QUAKE ERROR: SV_ModelIndex: model progs/v_shot.mdl not precached
Gila
2021-07-17 08:15:19

Yes, I got the same error - "v_shot.mdl not precached" message and crash (tested on vkQuake, which is a QS fork).

I'm not a mapper but I've extracted entities out of that BSP file and I noticed that worldspawn has spawnflags=2048. I'm not sure about that so I checked Quake Wiki on it: "The worldspawn entity has no spawnflags".

So I removed that line from .ENT file and enabled vkQuake to use external entities. This way, map loads in deathmatch no problem. Try removing spawnflags in worldspawn entity:

{
"classname" "worldspawn"
"message" "The Forgotten Base"
"sounds" "0"
"wad" "quake1.wad"
"worldtype" "2"
}

I would also advise to set sounds value from 4 to 11 so the map would have some music. Generally do not use "2" because it's Title/Quake Theme and don't use "3" because that's the intermission screen or level completed theme. Tracks 4 to 11 are used as ambient level music in Quake.

triple_agent
2021-07-17 08:10:34

@'Fat_Angus', no problem on my side apparently; using 'QSS' engine, edition from 8th July 2021; operating system is Ubuntu 20.04.2 LTS with Wayland protocol - here is a documentation video showing engine output details; the link will be dead sometime not too distant.

Fat_Angus
2021-07-17 07:40:00

Here's the compiled bsp file for your reference.  It'll get different results in different ports, i.e. DarkPlaces will run it, but with error messages: https://drive.google.com/file/d/1s3geSF … sp=sharing

negke
2021-07-17 06:23:06

v_shot.mdl is the shotgun model you see on screen - it's always precached. So the error message is quite strange.
Perhaps open the map file in a text editor and search for v_shot.mdl to see if it's possibly related to Netradiant's model viewer that could have slipped in a "model" field somewhere by accident.
Hard to tell like this; maybe post the map so people can examine it themselves.

Gila
2021-07-17 06:21:36

Two suggestions:

1. Try a separate "clean" install of Quake (just pak0.pak and pak1.pak in ID1 folder) and QuakeSpasm and run this map there

2. Upload compiled map somewhere so others can try it out, even if the map is still WIP

Fat_Angus
2021-07-17 04:55:53

SV_ModelIndex: model progs/v_shot.mdl not precached is what I'm getting with Quakespasm.

triple_agent
2021-07-17 03:58:45

What exact error messages does the engine give you, speaking of 'Quakespasm' - without here mentioning the entity names?

Fat_Angus
2021-07-17 03:41:03

Windows 10.  Latest version.


Although it must be noted this issue does not occur with the base game maps, both the DM only and SP maps, and even making a small test DM failed to reproduce this problem.  I did notice that health and ammo models were absent in my editor of choice (Netradiant-custom) and wondered if this was part of the problem, although running the map in Darkplaces reported sounds as well as models not being precached.

triple_agent
2021-07-17 03:28:07

@'Fat_Angus', what operating system do you use?

It could be a variable in some specific cases, although perhaps not to the point of a crash-to-desktop, I imagine.

Fat_Angus
2021-07-16 21:53:55

There are no mods running.  I run it in a standard DM mode in Quakespasm and Darkplaces.  Darkplaces runs the map but spits out precaching errors whenever sounds are played or models picked up or loaded.

Spirit
2021-07-16 14:47:55

CTD?

How exactly do you run it?

Any mods?

Fat_Angus
2021-07-16 11:53:39

I've run the map in darkplaces and it doesn't crash, but precaching errors keep coming up, especially those relating to sounds.  How do I fix this issue?

Fat_Angus
2021-07-16 11:24:38

I'm making a SP player map for Quake with deathmatch functionality.  When I try to run it in DM mode,I get a CTD in Quakespasm with the error message SV_ModelIndex: model progs/v_shot.mdl not precached.  What the hell is going on?  How do I fix this!

Board footer