You are not logged in.

#1 2016-09-06 07:12:48

Margrave
Member

Mission Pack 2 Status bar issues

I have noticed that, when playing Mission Pack 2 - Dissolution of Eternity (aka 'ROGUE') , there's a rather annoying problem with the status bar.

The armour / ammo icons displayed do not match the actual armour or weapon you have equipped. For example, the Shotgun displays the cells ammo icon (but the actual ammo count reflects the numbers of shells I have) and while wearing the green armour, no icon is displayed (but the number reflects the correct amount of armour).

Does anyone else have the same issue, and is there a patch or fix available? I've been searching on Google for quite a bit now, but I'm afraid the search terms are a bit too generic... Hence, my appeal to you for aid.

Thanks for your time!

#2 2016-09-06 11:24:00

bfg666
Member

Re: Mission Pack 2 Status bar issues

This sounds like a HUD problem on your end. Maybe you have or had a custom HUD that would cause a conflict?

#3 2016-09-06 13:24:04

Margrave
Member

Re: Mission Pack 2 Status bar issues

I use a PSP port (playstation portable) which runs a modified version of GLQuake. It works pretty well and I am able to play the base game and all official expansions, as well as some fan mods.

However, there's no custom HUD afaik. HUD looks normal everywhere else and the PAK file for MP2 was taken straight from the official disc.

My guess is that the inclusion of Lava Nails and Multi Rockets has 'shifted' the icons somehow, so it's probably fixable.

#4 2016-09-06 15:34:07

dwere
Member

Re: Mission Pack 2 Status bar issues

The HUD layouts are hardcoded in the engine, and each official expansion has its own. Perhaps the broken HUD is a result of using the default layout with MP2 gfx?

How do you launch the mission packs? On PC it's done by adding -hipnotic or -rogue to the command line, which enables respective HUDs, as well as loading the game data from the appropriate folders (no -game necessary, unless you're playing a mod).

Last edited by dwere (2016-09-06 15:47:15)

#5 2016-09-07 08:03:48

Margrave
Member

Re: Mission Pack 2 Status bar issues

dwere wrote:

Perhaps the broken HUD is a result of using the default layout with MP2 gfx?

==> That's entirely possible (and likely, even) but I have no idea how to fix that...

The structure of the game directories on the PSP is actually the same as on the PC. There's the ID1 directory with all the game files, plus a special 'EBOOT' file to make it work on the PSP. All mods / expansions have their own folder, situated on the same hierarchic level as ID1, just like the PC version. The guy who did the coding added a little file that prompts you to select the mod directory you want to use before starting the game (e.g. HIPNOTIC, ROGUE, DOPA, ALK15,...)

Normally, all you need to do to make a mod work is create the directory and copy the PAK (and other) files in there.

#6 2016-09-07 19:11:06

dwere
Member

Re: Mission Pack 2 Status bar issues

I just checked and running MP2 as a regular mod replicates the issue. Quakespasm still enables the correct HUD based on the mod directory (had to rename it to break the status bar), but GLQuake doesn't.

I'd say, if the PSP port is still being maintained, this issue should be reported.

#7 2016-09-08 07:38:26

Margrave
Member

Re: Mission Pack 2 Status bar issues

Thanks for confirming! Can't remember where I found it and don't know if it's still being maintained, but I'll definitely report the issue if able.

Quick reply

Write your message and submit
Are you human or robot? If you have trouble, mail to spirit åt quaddicted døt c

Checking if this is requested by a real person and not an automated program.

Board footer