You are not logged in.

#1 2018-06-10 11:59:25

Icantthinkofanickname
Moderator

QuakeSpasm 0.93.1 released

A new version of QuakeSpasm was released two days ago.

Here is the release announcement and changelog:

Version 0.93.1 of QuakeSpasm is released.
Changes since the previous version:

    Fixed a fog regression which was introduced in 0.93.0.
    Fixed a crash (buffer overflow) with invalid vis data.
    Fixed buttons crushing players in 64-bit builds.
    Change controller movement to use cubic easing by default; added
    joy_exponent_move cvar.
    config.cfg is no longer written in case of a Sys_Error().
    Fixed Opus encoded cd tracks not being recognized as ripped tracks.
    Update the third-party libraries. Other fixes/cleanups.

You can download QuakeSpasm 0.93.1 here or here.

#2 2018-06-19 16:47:37

TR2N
Member

Re: QuakeSpasm 0.93.1 released

Thanks for the heads up. Time to update i guess. Even though i never had issues with 0.93.

#3 2018-07-03 01:43:34

Butane
Member

Re: QuakeSpasm 0.93.1 released

Will the extra features/eye candy in Quakespasm-spike ever be added to the regular Quakespasm build? If not in the options menu at least maybe through console? I think a lot of people would appreciate that =)

#4 2018-07-03 18:09:46

dumptruck_ds
Member

Re: QuakeSpasm 0.93.1 released

@Butane I'm not sure that is going to happen. I think there will be an update to QS eventually, that includes separating the game fps from the rendering fps but I haven't heard of them adding the extra graphics capabilities.

#5 2019-06-21 11:51:23

Rufus Doofus
Guest

Re: QuakeSpasm 0.93.1 released

Both link to sourceforge and sourceforge is not working. Are there any reliable non sourceforge mirrors?

#7 2019-07-01 14:05:08

death112
Member

Re: QuakeSpasm 0.93.1 released

Any tips to improve FPS with quakespasm?
I've gotten a new laptop since a few week and quakespasm runs like garbage on it.

It does have AMD Ryzen 5 GPU with Radeon vega mobile gfx, so it should meet the specs with ease.
It ran pefrectly on the Acer Aspire 5

Thats my current cfg.

fov 			"110"
scr_showfps	"1"
scr_clock		"1"
host_maxfps 	"72"

// WEAPONS

bind "1" 		"impulse 1"// Axe
bind "2" 		"impulse 2"// Boomstick
bind "3" 		"impulse 3"// Supershotgun
bind "4" 		"impulse 6"// Grenade Launcher
bind "mouse4" 	"impulse 4"// Nailgun
bind "e" 		"impulse 4"// Nailgun if m4 cant be bound
bind "mouse5" 	"impulse 5"// Supernailgun
bind "5" 		"impulse 5"// Supernailgun if m5 cant be bound
bind "r" 		"impulse 7"// Lightning Gun
bind "f" 		"impulse 8"// Rocketlauncher

bind "9"	"impulse impulse 225"
bind "0"	"impulse 0"

// MOUSE - FOV
crosshair 		"1"
sensitivity 		"3.8"
lookspring 		"0"
lookstrafe 		"0"
sv_aim		"1"
m_forward 	"1"
m_pitch 	"0.022"
m_side 	"0.8"
m_yaw 	"0.022"

cl_bob	"0"// these should remove bob and roll crap
cl_bobup	"0"
cl_rollangle	"0"
//cl_bobbing 	"0"

v_kickpitch	"0"
v_kickroll		"0"
v_kicktime		"0"

// QUAKESPASM SETTINGS
gl_texturemode 	"GL_NEAREST_MIPMAP_NEAREST"// GL_LINEAR_MIPMAP_LINEAR
fov_adapt 		"1"
gamma 		"0.6"
contrast 		"1"
_snd_mixahead 	"0.1"
bgm_extmusic 	"1"
volume 		"0.35"
bgmvolume 	"0.2666"
cl_backspeed 	"400"
cl_forwardspeed "400"
cl_maxpitch 	"90"
cl_minpitch 	"-90"

external_ents 		"1"
gl_picmip			"0"
gl_farclip 			"16384"
gl_flashblend 		"0"
gl_fullbrights		"1"
gl_overbright 		"1"
gl_overbright_models 	"1"
gl_subdivide_size 	"32"
gl_texture_anisotropy "1"
gl_triplebuffer 		"0"

joy_enable 		"0"
joy_deadzone 		"0.175"
joy_deadzone_trigger "0.001"
joy_exponent 		"3"
joy_invert 			"0"
joy_sensitivity_pitch 	"150"
joy_sensitivity_yaw 	"300"
joy_swapmovelook 	"0"

r_fastsky		"0"
r_sky_quality 	"4"
fog			"0"
r_clearcolor 	"2"
r_novis 		"0"
r_oldwater 	"0"
r_particles 	"2"
r_quadparticles  "1"
r_shadows 	"0"
r_dynamic		"0"
r_waterwarp 	"0"
r_wateralpha	"0.2666" 		// allows you to see through water surfaces using an openGL engine and water vised maps.
r_lavaalpha	"0.2666"
r_slimealpha	"0.2666"
r_telealpha	"0"
r_waterquality	"1"

savedgamecfg 	"0"
saved1 		"0"
saved2 		"0"
saved3 		"0"
saved4 		"0"

scr_conalpha "0.5"
scr_conscale "3.3"
scr_conspeed "99999"
scr_conwidth "0"

scr_menuscale 	"3.3"
scr_sbaralpha 	"0"
scr_sbarscale 	"3.3"
scr_crosshairscale "2"
sv_altnoclip 	"1"
sys_throttle 	"0.22"

r_scale		"0"
vid_fullscreen 	"1"
vid_width 		"1920"
vid_height 	"1080"
vid_borderless 	"0"
vid_vsync 		"0"
viewsize 		"110"
vid_bpp 		"32"
vid_desktopfullscreen 	"0"
vid_fsaa 			"0"
vid_refreshrate 		"72"

vid_restart
+mlook

sorry, formatting in notepad was better :)

#8 2019-07-01 15:28:48

dumptruck_ds
Member

Re: QuakeSpasm 0.93.1 released

death112

You likely have to specifically set the laptop to use the GPU for Quakespasm. Take a look at your control panel. Hopefully this article applies to your setup:

https://us.answers.acer.com/app/answers … e-graphics

#9 2019-07-01 15:53:07

death112
Member

Re: QuakeSpasm 0.93.1 released

I did that already, forced to run it with main GPU

#10 2019-07-01 16:50:44

dumptruck_ds
Member

Re: QuakeSpasm 0.93.1 released

take a look at these console commands then:

r_fastsky. default 0. if 1, sky will be rendered as solid color, for added performance

r_sky_quality. default 8.  Higher number divides the sky more, for a smoother effect and slower performance.

#11 2019-07-01 17:06:21

death112
Member

Re: QuakeSpasm 0.93.1 released

Did try that but it didn't improve it unfortunately.
Btw im fiddling around with settings and testing in 'func_mapjamx' on 'jamx_naitelveni'.
The fps drops down to 20-30 there. On smaller maps it usually maintains 59-71 fps

#12 2019-07-01 17:36:49

dumptruck_ds
Member

Re: QuakeSpasm 0.93.1 released

That map has a lot of polys on screen at the same time. What resolution are you running? I have a laptop with a Radeon GPU and the control panel doesn't even come up. Such a pain. But anyway it's a 4k monitor. I run Quakespasm at 1920x1080 and seems to run fine. Your laptop is much newer and should run Quake with no problems.

Can you see what display adapter is being used from the console startup message? Look for gl_renderer

#13 2019-07-01 18:11:35

death112
Member

Re: QuakeSpasm 0.93.1 released

Im using the same resolution and the gl_renderer is 'Radeon RX 560X Series'
The Display says its Full HD ready with a 1080 sticker on it :p it can prolly do 4K

edit: and yes it should run Quake as it runs Doom2016 just fine with low settings

Last edited by death112 (2019-07-01 18:13:26)

#14 2019-07-02 00:58:41

dumptruck_ds
Member

Re: QuakeSpasm 0.93.1 released

I am at a loss then. Damn PC gaming strikes again.

#15 2019-07-02 10:00:48

death112
Member

Re: QuakeSpasm 0.93.1 released

is there a way to get my hands on an older build of quakespasm, say 0.90.0 ?

#16 2019-07-02 14:39:39

dumptruck_ds
Member

Re: QuakeSpasm 0.93.1 released

Yes right here: https://github.com/ericwa/Quakespasm/releases It's only the source code though.

Last edited by dumptruck_ds (2019-07-02 14:40:11)

#17 2019-07-02 16:12:31

death112
Member

Re: QuakeSpasm 0.93.1 released

Hmm, well thats to bad. Thought maybe an older build might solve the issue.
Thanks for your help anyways!

#18 2019-07-07 18:37:08

ericw
Member

Re: QuakeSpasm 0.93.1 released

Maybe give vkQuake a shot: https://github.com/Novum/vkQuake/releases (a Vulkan port of Quakespasm)
and MarkV: http://quakeone.com/markv/ (uses DirectX)

I suspect jamx_naitelveni will be cpu bound, it's got around 10K wpoly visible at the start location.

Quick reply

Write your message and submit
Are you human or robot? If you have trouble, mail to spirit åt quaddicted døt c

Checking if this is requested by a real person and not an automated program.

Board footer